Статьи Галерея Форум Чат Файлы HowTo Ссылки Поиск
Текущее время: 24 окт 2019, 01:10




Начать новую тему Ответить на тему  [ Сообщений: 23 ]  На страницу 1, 2  След.
Автор Сообщение
 Заголовок сообщения: [Error] Установка xmms
СообщениеДобавлено: 23 окт 2007, 12:20 
Интересующийся
Аватара пользователя

У нас с: 12.02.2006
Сообщения: 54
Откуда: Петропавловск-Камчатский
Доброго времени суток.
Сначал представлюсь ). :
Mandriva powerpack 2007
Kernel 2.6.17-13mdv
KDE 3.5.6
_____________________
Встроенные проигрыватели mp3 дико тупят. Решил устаноить xmms (говорят похож на виамп)
Скачал http://www.xmms.org/ xmms-1.2.10. в README написано

2.1 Basic Installation
----------------------

cd xmms-1.2.8
./configure
make
make install

This will put the binary in /usr/local/bin and plugins in
/usr/local/lib/xmms/

Запускаю из-под root ./configure
Начинает паковать....

checking for glib-config... no
checking for GLIB - version >= 1.2.2... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

Пока не могу понять что он от меня хочет ???

Идём далее. Запускаю make Вообще такой комадны не знает (bash), до этого ставил лингву и mova запускал через qmake. В папке есть файлы filemake.am
filemake.in

[root@admin xmms-1.2.10]# qmake install
Error processing project file: /usr/local/bin/xmms-1.2.10/install
.
Как его Поставить ?
:?:


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 23 окт 2007, 12:51 
Фанатеющий
Аватара пользователя

У нас с: 10.09.2006
Сообщения: 151
Откуда: Минск
Достаточно просто. Сначала установи glib-1.2.10. Не путай с glibc или glib-2. В системе с КДЕ скорее всего стоит глиб-2, а первую нужно ставить дополнительно. Также нужен GTK-1.2.10. После этого пойдет работать. По идее, в дистре должно быть все, в т.ч. и xmms. Но! Учти - поставишь из сорцов, бед не оберешься. Патчить нужно отчаянно, чтоб русский понимал. Лучше попробуй Audacious. И русский знает, и на xmms c winamp похож.

_________________
Сомневаюсь, и вам советую!


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 23 окт 2007, 20:33 
Неотъемлемая часть форума
Аватара пользователя

У нас с: 20.03.2006
Сообщения: 259
Откуда: г. Минск
mungo, +1.
xmms зроблены на састарэлай бібліятэцы й не разумее utf8.
Audacious - шмат лепей (што датычыць да працы з тэгамі), але жарэ процьму памяці дзеля праграмы, што будзе працаваць бесьперапынна.


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 23 окт 2007, 23:10 
Маньяк
Аватара пользователя

У нас с: 16.04.2005
Сообщения: 186
Откуда: Kiev
qmake - всего лишь частный (и редкий) случай сборки прог на QT, которые специально заточены под QT .
А вообще (книгу потолще по Линуху купи!) при сборке прог, когда командуешь ./configure, система шмонается на предмет нужных для сборки и работы собираемой программы библиотек и всего остального. Определяется их расположение, параметры, версии. Если чего не так - ругается.
Если всё в порядке, создаёт Makefile, согласно которому собирается программа по команде make. Т.е. пока configure не отработал, Makefile нет, команда make ругается, что нет правил для сборки цели.
После сборки прога уже. вобщем, работоспособна - знает куда за какими библиотеками обращаться и всё такое. Теоретически, её даже можно запустить прямо отсюда, или мышкой растащить по нужным каталогам... если делать нечего :)
Но в Makefile предусмотрены и инструкции, чего куда пихать для полноценной работы. После выполнения make install, программа, как правило, готова к работе.

В данном случае, проблема в отсутствии библиотеки glib-1.2.10. Если установить её (предположительно glib-1.2.10-бла-бла-бла.rpm и glib-devel-1,2,10-бла-бла-бла.rpm), configure теперь этот этап благополучно проскочит, записав в Makefile, где искать glib-1.2.10. Скорее всего, споткнётся потом ещё обо что-нибудь :). Снова удовлетворяем зависимости - и так до победного.

Если команда make вообще неизвестна, нужно установить пакет make-бла-бла.rpm.

Если make install запускается НЕ из-под рута, система тоже посылает, а предыдущие команды запускаются из-под юзера.

Если есть желание самому собирать программы, есть смысл поставить с диска всю пачку пакетов для разработчиков - тогда ./configure будет ругаться гораздо реже.

Ущё пара ньюансов: библиотеки (lib* луше самостоятельно не собирать - долго рассказывать, как потом системе её показать ( читай man ldconfig), программы, собранные самостоятельно, в упор не видит система rpm.Т.е. собираем что-то, оно нормально работает в системе. Потом нам нужно поставить rpm-пакет, которому это что-то нужно, а он ругается, что этого нет.ЗАДОЛБАТЬСЯ можно. Но можно и заставить работать :) . Та же фигня с чужими rpm.

На закуску: если набрать ./configure -h или ./configure --help, увидишь, как тонко можно настроить сборку-установку конкретной программы из исходников.

_________________
:) Обчитайтесь умных статей о Линуксе: http://www.mycomputer.ua/list/arts_soft_non-windows - в журнале "Мой компьютер" (Украина, русский язык)


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 03:56 
Интересующийся
Аватара пользователя

У нас с: 12.02.2006
Сообщения: 54
Откуда: Петропавловск-Камчатский
mungo писал(а):
Но! Учти - поставишь из сорцов, бед не оберешься. Патчить нужно отчаянно, чтоб русский понимал.

Не понимаю "сорцов" енто что ? И почему ставить не надо ?.> Русский имеешь в Плейлисте ? чтобы названия песен распозновал ? "Лучше попробуй Audacious." Спасибо обязательно попробую.



kisa писал(а):
при сборке прог, когда командуешь ./configure, система шмонается на предмет нужных для сборки и работы собираемой программы библиотек и всего остального. Определяется их расположение, параметры, версии. Если чего не так - ругается.
Если всё в порядке, создаёт Makefile, согласно которому собирается программа по команде make. Т.е

Ага, на сколько я понял makefile.in and makefile.am это всеголишь файли незаконченой компиляции makefile ? т.е если всё прошло был бы 1 фаил Makefile. ?
kisa писал(а):
книгу потолще по Линуху купи!)

Обязательно куплю. Пока Инет мне помогает.
Спасибо ещё на пробывал но сегодня обязатель обновлю.
"kisa" Описал так описал. сразу стало понятно куда дальше рыть. ) :D


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 12:05 
Интересующийся
Аватара пользователя

У нас с: 12.02.2006
Сообщения: 54
Откуда: Петропавловск-Камчатский
...........:oops:
Всем ещё раз привет.
Вообщем у меня всё равно не получается. Замкнутый круг какой-то.
Скачиваю make*rpm ставлю.
Скачал audacious-1.3.2, распкавал ./configure

checking for glib-2.0 >= 2.6.0 gtk+-2.0 >= 2.6.0 gthread-2.0 pango... no
configure: error: Cannot find glib2/gtk2/pango


Ага всё ясно отправляюсь за glib-2.0
ftp://ftp.gtk.org/pub/glib/2.12/glib-2.12.13.tar.gz

Распаковываю, ./configure
make
................
make[4]: Цель `all' не требует выполнения команд.
make[1]: Leaving directory `/home/alexey/install/glib-2.12.13'
Делаю Makefile
bash: /usr/local/bin/Makefile: Отказано в доступе (root)

хм..... забиваю скачиваю пакет glib
ftp://mirror.switch.ch/mirror/mandrake/ ... 1.i586.rpm
ставлю.
Ладно что-то там пыхтело будем считать что поставилось.

Скачиваю
ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-2.10.14.tar.bz2
./configure
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met:

No package 'atk' found
No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Скачиваю
tp://ftp.gtk.org/pub/pango/1.16/pango-1.16.4.tar.bz2
./configure
make

...........
make[2]: Leaving directory `/home/alexey/install/pango-1.16.4'
make[1]: Leaving directory `/home/alexey/install/pango-1.16.4'
Ну вроде поставилось.
Из вот этого списка checking for glib-2.0 >= 2.6.0 gtk+-2.0 >= 2.6.0 gthread-2.0 pango.
Вроде бы всё поставил.
Начинаю ставить проигрывтель....
То же сомое пишет...
ставлю gtk+-2.10.14 .
No package 'atk' found
No package 'pango' found
No package 'cairo' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Мда... Вот скажи те мне не смотри на то что я уже поставил pango' всё равно его указывает.! ( Дальнейшие действия мой ?
Скачивать cairo и Atk ?? Просто у меня создаётся такое впечатлене что этому конца и краю нет (((

_________________
Любишь кататься- люби и катайся!


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 12:36 
Неотъемлемая часть форума
Аватара пользователя

У нас с: 06.02.2002
Сообщения: 9760
Откуда: Менск
Deltree, в дистрибутиве есть либо beep-media-player либо audacoius - нет никаких причин продолжать насиловать труп xmms.

_________________
Опыт растет прямо пропорционально выведенному из строя оборудованию


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 12:51 
Интересующийся
Аватара пользователя

У нас с: 12.02.2006
Сообщения: 54
Откуда: Петропавловск-Камчатский
Цитата:
Достаточно просто. Сначала установи glib-1.2.10. Не путай с glibc или glib-2. В системе с КДЕ скорее всего стоит глиб-2, а первую нужно ставить дополнительно. Также нужен GTK-1.2.10.
Невнемательно прочитал. Сделаю по инструкции

Llama, На счёт audacoius незнаю завтра попробую.А Xmms и в правду труп щас из его дир. ./configure Вообще уже не пакует ))) Ну ладно На него забил. С audacoius посмотрю пакет. Мне просто необходимо разодраться в чём всё таки причина ?? Я как всем понятно начинающий linux-ойд. Решение простое Юзай 2 встроенных mp3 плеера. И не Мучай голову Знающим ребятам с Форума.! Но всё таки если не сложно подскажите.
Я так понимаю что *rpm (пакеты) Намного проще ставятся. Но не все библиотеки в *rpm ВЫкладываются на сайтах. Завтра я установлю все пакеты с диска. Все таки powerpack Должно быть. Спасибо зарание

_________________
Любишь кататься- люби и катайся!


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 14:06 
Неотъемлемая часть форума

У нас с: 19.08.2004
Сообщения: 209
Deltree, открой для себя http://rpmfind.net/


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 14:24 
Маньяк
Аватара пользователя

У нас с: 16.04.2005
Сообщения: 186
Откуда: Kiev
makefile.in and makefile.am - можно сказать, заготовки. Во всяком случае, они остаются, добавляется Makefile - вот так, с большой буквы и без расширений.Вкстате, после ./configure и make в папке с прогой живут исходники плюс собраная прога и её Makefile. Если она уже установлена с помощью make install, деинсталировать её часто можно при помощи make uninstall. Если нужно пересобрать её с другими опциями ./configure (напр. для установки в /opt вместо /usr/local, или включить/выключить поддержку чего-нибудь, короче см. ./configure --help конкретной проги) , нужно дать команду make clean. Тогда будет удалён Makefile и собранные куски программы, т.е. папка примет такой вид, как будто ты её только что скачал и распаковал.

Теперь важнейший для порядка в голове момент(упрощённо). Програмёры пишут собственно исходный код -пока не программу. Машине (конкретно процессору) эти буквы, цифры и команды.. эээ... до спины - ей нужны процессорные инструкции. Для этого в винде запускают компиллятор, который и собирает из исходного кода файл бла-бла.exe - собственно рабочую прогу Блабла. Потом эту программу тем или иным способом распространяют среди пользователей винды (продают, взламывают, воруют... :) ). Как правило, этот *.exe включают в другую программу - инсталятор (напр. setup.exe), который показывает лицензию, задаёт дурные вопросы, потом помещает, куда надо *.exe и всякие иконки для доступа, добавляет записи в реестр. В результате пользователь винды получает готовый продукт в конкретной конфигурации. При этом исходный код ("сорцы", "сырцы","исходники","source","source code"..) часто тщательно скрываются - типа ноу-хау-сам-всё-схау.

Традиционно в Линуксе автор распространяет свою программу прямо в виде исходников (папка с ними пакуется в *.tar.gz, *.tar.bz,*.tar.bz2 - отличаются размером, но не содержимым) с которыми пользователь волен делать всё, что угодно, вплоть до переделки под свои нужды самого кода программы. Все обычно так и делают :). Шутка. Но пользователь может собрать программу под свой проц, с поддержкой только своего языка, повыкинуть поддержку ненужных ему функций, указать, где лежат нужные проге библиотеки, если та сама не нашла и т.д. Автор предусматривает это на этапе ,/ configure (снова см. ./configure --help данной проги, там же указывают, какие опции выставлены по умолчанию) . Выглядит это примерно так:
Код:
 ./ configure --prefix=/opt --with-kde --without-gnome --with-ogg --without-mp3 --with-x

Пример от фонаря, но похож на правду. В данном примере пога будет собрана для установки в каталог /opt, поддержку КДЕ улучшить, Гнома - выкинуть, работать будем со звуком формата ogg, mp3- выкидываем, возможность работы в иксах подключаем. В простейшем случае, не заморачиваемся, собираем с авторскими опциями - просто ./configure. Дальше я бегло рассказывал.

Но не всем в радость заниматься таким шаманством. Производители дистров идут навстречу пользователям,и развивают разные пакетные системы. В моём Slackware это пакеты *.tgz; в Lindows/Linspire,Debian и Ubuntu - *.deb; в Suse, Mandrake/Mandriva, ASP, Alt, RedHat/Fedora - *.rpm. RPM - это тоже особый архив. Ради любопытства в него можно зайти в консоли при помощи mc. Внутри видим несколько файлов с характеристиками совместимости и т.п., файл install, который запускает установку, и собственно устанавливаемые файлы, рассованые по папкам внутри rpm. Откуда это берётся?
Кто-то добрый до нас взял исходники, сконфигурировал (configure) и откомпилировал (make) программу по своему усмотрению (про опции см. выше). Но устанавливать (make install) не стал, а запаковал это в *rpm, и подарил нам через инет, или недорого продал на диске. Причём, ИСХОДНИКОВ В ПАКЕТЕ УЖЕ НЕТ - ТОЛЬКО ИСПОЛНЯЕМЫЕ ФАЙЛЫ И ФАЙЛЫ КОНФИГУРАЦИИ, да картинки-иконки.Теперь нам достаточно сделать двойной клик на этом пакете, чтобы запустилась установка. Или в консоли в папке с рпмкой дать команду rpm -Uhv бла-бла.rpm .

НО! У доброго человека на машине столяли такие-то библиотеки ИМЕННО таких-то версий, ИМЕННО в таких-то папках, и в ./configure он сказал нашей проге установиться туда-то. Причём вся эта прелесть, от которой наша прога зависит, тоже была установлена при помощи rpm.
Первым делом система проверяет, установлены ли пакеты с прелестью, причём она не шмонает всю систему в поисках библиотек, а тупо просматривает список установленных rpm-пакетов. Нету библиотеки? - "До свидания, сначала установите такие-то пакеты". Т.е. если я эту библиотеку сам собрал из исходников - систему rpm это не волнует. Пакет ей родной нужен.Мандрива, правда, сама предлагает доустановить то, что нужно.То же происходит с рпмками от другого дистра. Я когда-то развлекался, пихая пакеты от Suse в Mandrake - устанавливал без проверки зависимостей, запускал из консоли, смотрел, где оно что ищет, делал симлинки из места, где оно ищет, в место, где реально лежат нужные файлы (у них даже KDE по разным каталогам лежит) - увлекательно :) . Всё это описано в литературе. Чтобы не мучится, конечно, можно найти rpm-пакет с xmms под твою Mandriv'у, подозреваю, что прямо на их сайте и со всеми зависимыми пакетами.

Для добавления новых функций в чужую программу выпускают патчи - исправления. Берём сырцы, распаковываем, применяем патч - там некоторые файлы соответственно изменятся, и после конфигурирования - сборки - установки программа обретёт новые функции. Например, я пропатчил свой mc для работы с Юникодом.

Книги. Литературу типа "Для чайников", "Линукс за три часа", "Читая меньше-узнавай больше" (ваще улёт - лежат такие в магазинах) следует выбирать по качеству бумаги. Она должна быть мягкой и нежной.
Серъёзных книг по Линукс у меня три (600-900 стр, мелочи не считаем) :
Д.Колисниченко "Самоучитель Linux"
Д. Бендел, Р. Нейпир "Использование Linux"
М. Кофлер "Весь Linux"
Приобретались с интервалом год-два, каждую выжимал до предела, потом покупал следующую. Конечно, регулярно возвращаюсь к "выжатым" - там ещё стоолько остаётся!
Обходится только инетом не очень... гигиенично. Иногда в системе такого наворотишь - в инет выйти не на чем. Правда, спасает спасательный дистр (я привык к SLAX)
Тебе достаточно книги в 597 страниц - три я уже пересказал :)

_________________
:) Обчитайтесь умных статей о Линуксе: http://www.mycomputer.ua/list/arts_soft_non-windows - в журнале "Мой компьютер" (Украина, русский язык)


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 18:10 
Маньяк
Аватара пользователя

У нас с: 16.04.2005
Сообщения: 186
Откуда: Kiev
После установки любой библиотеки системе нужно её показать. Для этого предназначена команда /sbin/ldconfig. До того никакая система в упор её не увидит. Часто ldconfig выполняется автоматически при перезагрузки системы, или установки пакета rpm с библиотекой. Короче, никогда не вредно после установки любой *lib*любым способом (как правило, в названии библиотек содержится *lib*) , выполнить ldconfig. В файле /etc/ld.so.conf указаны каталоги, где ищутся новые библиотеки. Желательно подописывать туда все каталоги, куда только могут ставиться библиотеки - вплоть до /home/kisa/[пи]/negrityanki/video/lib :).
Все такие папки называются lib. Причём, если есть,например, каталог /usr/lib , в нём - куча библиотечных файлов и каталоги /qt и /lib, в каждом из них тоже файлы, а в /qt ещё один каталог /lib (вникай! :) ), записи о них в /etc/ld.so.conf должны выглядеть так:
Код:
/usr/lib
/usr/lib/lib
/usr/lib/qt/lib

т.е. прямой полный путь ко всем каталогам lib(можно поискать их поиском файлов). Особенно это важно при самосборных библиотеках, которые (если при ./configure другого не укажешь) ставятся куда-нить в /opt или в /usr/lib, а у тебя путь /usr/lib может быть и не указан.
И ещё: для самостоятельной сборки в Mandriv'е нужно ставить пакеты не только типа lib*.rpm, но и lib*-devel.rpm. (ну, в Манрейк так было)Простые (облегчённые) библиотеки предназначены только для работы программ, а "devel" - и для сборки.

_________________
:) Обчитайтесь умных статей о Линуксе: http://www.mycomputer.ua/list/arts_soft_non-windows - в журнале "Мой компьютер" (Украина, русский язык)


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 18:20 
Фанатеющий
Аватара пользователя

У нас с: 10.09.2006
Сообщения: 151
Откуда: Минск
Deltree, а если вдруг, как я, считаешь нужным собирать пакеты самому, то почитай http://www.linuxfromscratch.org/blfs/view/svn/.
Там про каждый пакет и зависимости тьма инфы. Правда, на аглицком :?

_________________
Сомневаюсь, и вам советую!


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 24 окт 2007, 18:26 
Маньяк
Аватара пользователя

У нас с: 16.04.2005
Сообщения: 186
Откуда: Kiev
mungo, я на эту штуку разных версий натыкался и по-русски.Да хотябы вот: http://www.google.ru/linux?complete=1&h ... lr=lang_ru А ты что, сам собрал рабочий LFS?!! Я ниасилил - медленно очень, но тренировки оказались полезными :)

_________________
:) Обчитайтесь умных статей о Линуксе: http://www.mycomputer.ua/list/arts_soft_non-windows - в журнале "Мой компьютер" (Украина, русский язык)


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 25 окт 2007, 18:17 
Фанатеющий
Аватара пользователя

У нас с: 10.09.2006
Сообщения: 151
Откуда: Минск
Полностью. С КДЕ, офисом, и кучей всякой всячины. Когда написал скрипты, то сама сборка (собираю исключительно в варе) заняла 1,5 недели (по вечерам после работы).
А читать надо оригинал - он всегда гораздо свежее :)

_________________
Сомневаюсь, и вам советую!


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
 Заголовок сообщения:
СообщениеДобавлено: 25 окт 2007, 19:15 
Маньяк
Аватара пользователя

У нас с: 16.04.2005
Сообщения: 186
Откуда: Kiev
Фигасе... Орёл, однако! А я до скриптов не додумался тогда. Да там не столько свежесть, сколько сам процесс важен. У меня инет был тогда телефонный, поэтому качал только книгу, а исходники брал с диска Slackware 9 - как раз версии всего примерно совпадали.

_________________
:) Обчитайтесь умных статей о Линуксе: http://www.mycomputer.ua/list/arts_soft_non-windows - в журнале "Мой компьютер" (Украина, русский язык)


Вернуться к началу
 Не в сети Профиль  
Ответить с цитатой  
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 23 ]  На страницу 1, 2  След.


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
[ All resources are available under GNU GPL ] [ Support ] [ Hosted by DataHata | MyCloud.by ] [ Powered by phpBB® Forum Software © phpBB Group ]

LVEE Winter LVEE Rambler's Top100