Проблема с установкой программ

Форум предназначен для новичков. В нем предполагается рассматривать вопросы, которые встают на первых этапах освоения Linux
Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Если честно, мне самому всё это интересно, хочется разобраться и порыться в литературе, но нет времени... Совсем нету((( Поэтому я и обращаюсь сюда за помощью, чтобы установить хотя бы самое необходимое ПО (icq, realtek (в стандартном драйвере я не нашёл нужных мне настроек), ну и впринципе пока всё, с wine справился сам).

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Anti писал(а):
вот вполне похожая на правду ссылка с рецептом (вторая в гугле по запросу ubuntu aptitude proxy):

export http_proxy=http://username:password@proxyserver.net:port/ знакомая команда, но у меня выдаёт ошибку. А дисков нету никаких...

Ну дык разумеется
sudo su
export http_proxy="http://username:password@proxyserver.net:port/"
apt-get update (кажется, так)
apt-get install pidgin

И вообще, в бубунте же графический менеджер пакетов с возможностью настройки прокси, насколько я помню. Зачем этот секс?

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

sudo su

За эту комманду спасибо, очень помогла)))
apt-get update

W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dis ... Sources.gz 407 Proxy Authentication Required
Даже несмотря на то, что в apt.conf всё прописано, с авторизацией.

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Кстати вот такой вопрос, как обновить версию компилятора с помощью пакетов (apt-get и т.п. не помогают). А то многие программы не могу установить (к примеру rpm, yum, gaim), "обновить систему, а вместе с ней и он обновится" - не обновился((( А гуглить уже задолбался :shock:

Аватара пользователя
grub
Неотъемлемая часть форума
Сообщения: 849
Зарегистрирован: 13 сен 2006, 10:29
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение grub »

Anti, давайте разберемся по порядку.

1) В другом топике Вы написали, что apt заработал. То есть проблему с прокси Вы таки решили?
2) Для чего тогда rpm/yum? :shock: Поверьте, это ОЧЕНЬ плохая идея, прикручивать их к убунте вместо того чтобы разобраться с родным пакетным менеджером и репозиториями. Если хотите, могу объяснить, почему.
3) Если "более новая версия компилятора" нужна для того, чтобы самостоятельно пособирать программы, отчаявшись разобраться с apt/aptitude -- см.п.2. Этого также не стоит делать, потому что все операции "подгонки" софтины к особенностям конкретного дистрибутива уже давно сделаны за Вас майнтейнерами пакетов. Вы же просто самостоятельно пойдете по тем же граблям, причем вряд ли с лучшим результатом. Представление о типичном характере "граблей" можно получить из первого поста в данном топике. Такого будет много.
И кроме того придется самостоятельно помнить о том, какой софт какую библиотеку требует, что отвалится при обновлении, что конфликтует и т.п. -- то есть самому работать пакетным менеджером. :) Давайте лучше доверим эту скучную работу apt/aptitude? ;-)
4) gaim есть в репозиториях debian (правда, он уж давно переименован в pidgin и пакет gaim соответственно является лишь "перенаправлялкой" на правильный pidgin). Значит, будет и в репозиториях убунты. Значит, если он у Вас не ставится -- скорее всего, еще не до конца корректно настроен apt. Вот эту проблему порешать стоит (в т.ч. с помощью данного топика). Это правильный путь, и отдача от однократных усилий будет гораздо выше, чем от описанных выше вариантов. Так что давайте для начала попробуем посмотреть на содержимое Вашего /etc/apt/sources.list

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Anti писал(а):W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dis ... Sources.gz 407 Proxy Authentication Required
Даже несмотря на то, что в apt.conf всё прописано, с авторизацией.

Ну так ты прокси либо в apt настраивай, либо в bash :\

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Да, действительно, лучше разобраться в том что есть...
Содержимое /etc/apt/sources.list:
# deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://ru.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic universe
deb http://ru.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ru.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://ru.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
# deb-src http://ru.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu karmic partner
# deb-src http://archive.canonical.com/ubuntu karmic partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse


Аватара пользователя
grub
Неотъемлемая часть форума
Сообщения: 849
Зарегистрирован: 13 сен 2006, 10:29
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение grub »

Вроде выглядит нормально.
Теперь попробуйте сделать sudo aptitude update (чтобы обновить кэш пакетов).
И после этого aptitude install pidgin.

И посмотрите, что будет писать, какие конкретно сообщения об ошибках (если они будут).

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Вот такая вот ошибка вылезла

root@yegor-desktop:/home/yegor# sudo aptitude update
Writing extended state information... Готово
Ign http://ru.archive.ubuntu.com karmic Release.gpg
Ign http://ppa.launchpad.net karmic Release.gpg
Ign http://ru.archive.ubuntu.com karmic/main Translation-ru
Ign http://ppa.launchpad.net karmic/main Translation-ru
Ign http://security.ubuntu.com karmic-security Release.gpg
Ign http://ru.archive.ubuntu.com karmic/restricted Translation-ru
Ign http://ru.archive.ubuntu.com karmic/universe Translation-ru
Ign http://security.ubuntu.com karmic-security/main Translation-ru
Ign http://ppa.launchpad.net karmic Release
Ign http://security.ubuntu.com karmic-security/restricted Translation-ru
Ign http://ru.archive.ubuntu.com karmic/multiverse Translation-ru
Ign http://security.ubuntu.com karmic-security/universe Translation-ru
Ign http://ru.archive.ubuntu.com karmic-updates Release.gpg
Ign http://ppa.launchpad.net karmic/main Packages
Ign http://ru.archive.ubuntu.com karmic-updates/main Translation-ru
Ign http://ppa.launchpad.net karmic/main Packages
Ign http://security.ubuntu.com karmic-security/multiverse Translation-ru
Ign http://ru.archive.ubuntu.com karmic-updates/restricted Translation-ru
Err http://ppa.launchpad.net karmic/main Packages
407 Proxy Authentication Required
Ign http://security.ubuntu.com karmic-security Release
Ign http://ru.archive.ubuntu.com karmic-updates/universe Translation-ru
Ign http://security.ubuntu.com karmic-security/main Packages
Ign http://ru.archive.ubuntu.com karmic-updates/multiverse Translation-ru
Ign http://ru.archive.ubuntu.com karmic Release
Ign http://security.ubuntu.com karmic-security/restricted Packages
Ign http://ru.archive.ubuntu.com karmic-updates Release
Ign http://security.ubuntu.com karmic-security/main Sources
Ign http://security.ubuntu.com karmic-security/restricted Sources
Ign http://security.ubuntu.com karmic-security/universe Packages
Ign http://ru.archive.ubuntu.com karmic/main Packages
Ign http://ru.archive.ubuntu.com karmic/restricted Packages
Ign http://security.ubuntu.com karmic-security/universe Sources
Ign http://ru.archive.ubuntu.com karmic/main Sources
Ign http://security.ubuntu.com karmic-security/multiverse Packages
Ign http://security.ubuntu.com karmic-security/multiverse Sources
Ign http://ru.archive.ubuntu.com karmic/restricted Sources
Ign http://security.ubuntu.com karmic-security/main Packages
Ign http://ru.archive.ubuntu.com karmic/universe Packages
Ign http://security.ubuntu.com karmic-security/restricted Packages
Ign http://ru.archive.ubuntu.com karmic/universe Sources
Ign http://security.ubuntu.com karmic-security/main Sources
Ign http://ru.archive.ubuntu.com karmic/multiverse Packages
Ign http://security.ubuntu.com karmic-security/restricted Sources
Ign http://ru.archive.ubuntu.com karmic/multiverse Sources
Ign http://ru.archive.ubuntu.com karmic-updates/main Packages
Ign http://security.ubuntu.com karmic-security/universe Packages
Ign http://ru.archive.ubuntu.com karmic-updates/restricted Packages
Ign http://security.ubuntu.com karmic-security/universe Sources
Ign http://ru.archive.ubuntu.com karmic-updates/main Sources
Ign http://security.ubuntu.com karmic-security/multiverse Packages
Ign http://ru.archive.ubuntu.com karmic-updates/restricted Sources
Ign http://security.ubuntu.com karmic-security/multiverse Sources
Ign http://ru.archive.ubuntu.com karmic-updates/universe Packages
Err http://security.ubuntu.com karmic-security/main Packages
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic-updates/universe Sources
Err http://security.ubuntu.com karmic-security/restricted Packages
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic-updates/multiverse Packages
Ign http://ru.archive.ubuntu.com karmic-updates/multiverse Sources
Err http://security.ubuntu.com karmic-security/main Sources
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic/main Packages
Err http://security.ubuntu.com karmic-security/restricted Sources
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic/restricted Packages
Err http://security.ubuntu.com karmic-security/universe Packages
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic/main Sources
Err http://security.ubuntu.com karmic-security/universe Sources
407 Proxy Authentication Required
Err http://security.ubuntu.com karmic-security/multiverse Packages
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic/restricted Sources
Err http://security.ubuntu.com karmic-security/multiverse Sources
407 Proxy Authentication Required
Ign http://ru.archive.ubuntu.com karmic/universe Packages
Ign http://ru.archive.ubuntu.com karmic/universe Sources
Ign http://ru.archive.ubuntu.com karmic/multiverse Packages
Ign http://ru.archive.ubuntu.com karmic/multiverse Sources
Ign http://ru.archive.ubuntu.com karmic-updates/main Packages
Ign http://ru.archive.ubuntu.com karmic-updates/restricted Packages
Ign http://ru.archive.ubuntu.com karmic-updates/main Sources
Ign http://ru.archive.ubuntu.com karmic-updates/restricted Sources
Ign http://ru.archive.ubuntu.com karmic-updates/universe Packages
Ign http://ru.archive.ubuntu.com karmic-updates/universe Sources
Ign http://ru.archive.ubuntu.com karmic-updates/multiverse Packages
Ign http://ru.archive.ubuntu.com karmic-updates/multiverse Sources
Err http://ru.archive.ubuntu.com karmic/main Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/restricted Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/main Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/restricted Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/universe Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/universe Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/multiverse Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic/multiverse Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/main Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/restricted Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/main Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/restricted Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/universe Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/universe Sources
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/multiverse Packages
407 Proxy Authentication Required
Err http://ru.archive.ubuntu.com karmic-updates/multiverse Sources
407 Proxy Authentication Required
Чтение списков пакетов... Готово

Аватара пользователя
grub
Неотъемлемая часть форума
Сообщения: 849
Зарегистрирован: 13 сен 2006, 10:29
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение grub »

ага, значит, прокси таки не побежден... возвращаемся на предыдущий этап.
прокси как по итогу настроен? через apt.conf?

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Наверное не самый рациональный не вариант,
1) Создал на рабочем столе файл apt.conf и записал туда
Acquire::http::proxy "http://username:password@proxyserver:port/";
естественно вместо username там логин и т.д.
2) С административными правами через коммандную строку удалил /etc/apt/apt.conf
3) Аналогично скопировал туда файл с рабочего стола.

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »


Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Эта ссылка мне никак не помогла!!! У меня там всё так, как там... Прокси в /etc/apt/apt.conf прописаны. В система - настройки - nerwork proxy всё как надо. Я и говорю о том что работает только обновление системы, а apt-get update или apt-get install *** нет! В предпредыдущем своём сообщение указал какую ошибку выдаёт.

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Anti писал(а):Эта ссылка мне никак не помогла!!! У меня там всё так, как там... Прокси в /etc/apt/apt.conf прописаны. В система - настройки - nerwork proxy всё как надо. Я и говорю о том что работает только обновление системы, а apt-get update или apt-get install *** нет! В предпредыдущем своём сообщение указал какую ошибку выдаёт.

Если тебе лень прочесть больше двух строчек, то тебе уже ничего не поможет.
Возможно, нужно сделать вот это :
I don't know if anyone still has this problem, but I found my solution in another post.

The steps mentioned here earlier are good and all, BUT if those of you who's got this problem is in a Windows environment with a Microsoft ISA Proxy that need authentication, this is the solution that worked for me:

You need to install NTLMAPS...


P.S. Я , конечно, понимаю, помогать нужно новичкам, но скатываться в такой детский сад - это уже чересчур :\

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

You need to install NTLMAPS...


Спасибо, но нашёл способ намного проще и всё заработало!!!! :P

Ответить