Проблема с установкой программ

Форум предназначен для новичков. В нем предполагается рассматривать вопросы, которые встают на первых этапах освоения Linux
Аватара пользователя
grub
Неотъемлемая часть форума
Сообщения: 849
Зарегистрирован: 13 сен 2006, 10:29
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение grub »

Anti, поделитесь способом. Мало ли, в будущем у кого-то возникнут такие же проблемы.

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

Я прописал в /etc/apt/apt.conf

Acquire::http::proxy "http://login:password@proxy:port/";
Acquire::https::proxy "https://login:password@proxy:port/";
Acquire::ftp::proxy "ftp://login:password@proxy:port/";


И в /etc/enviroment

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
http_proxy="http://login:password@proxy:port/"
https_proxy="https://login:password@proxy:port/"
ftp_proxy="ftp://login:password@proxy:port/"


Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Второй части было бы достаточно

Anti
Заглянувший
Сообщения: 32
Зарегистрирован: 13 фев 2010, 17:48

Re: Проблема с установкой программ

Сообщение Anti »

А вот теперь новая проблема. Посоветовали мне ICQ клиент qutIM. С его установкой возникли проблемы:
sudo apt-get install qutim
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
E: Не удалось найти пакет qutim
Захожу на packages.ubuntu.com, скачиваю оттуда пакет. При установке он мне пишет, что нет пакета libqt4-network (>= 4:4.6.0). Захожу в менеджер пакетов, ввожу название и вижу, что libqt4-network установлен, но версия (= 4.5.3really4.5.2-0ubuntu1). Флажок "для обновления" не ставится, sudo apt-get upgrade libqt4-network говорит, что уже установлена новейшая версия.
Добавил в /etc/apt/sources.list deb http://cz.archive.ubuntu.com/ubuntu lucid main, как раз то, что и предлагал мне ввести сайт в обмен на скачивание всех пакетов вручную. Обновил список пакетов, но ситуация не исправилась. :( Вручную скачал libqt4-network 4:4.6.1, установил, установщик qutim пишет что ему не хватает ещё одного пакета и т.д. В итоге потребовал пакет, который также не обновлялся, а удаление старого влекло за собой, наверное, удаление половины вообще всех установленых пакетов, если не больше. :shock: Так как всё-таки установить эту программу?

Ларин
Неотъемлемая часть форума
Сообщения: 484
Зарегистрирован: 19 ноя 2007, 15:01
Контактная информация:

Re: Проблема с установкой программ

Сообщение Ларин »

Two of the most famous products of Berkeley are LSD and BSD:)

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Перед тем, как что-то обновлять, нужно обновить список пакетов с зеркала.
apt-get update

Virgil
Неотъемлемая часть форума
Сообщения: 563
Зарегистрирован: 13 янв 2009, 01:33

Re: Проблема с установкой программ

Сообщение Virgil »

В GNU/Linux нельзя использовать очень старые версии программ, если всё время обновляешь дистрибутивы и ПО? Тогда не будут удоволетворены зависимости? Например, я использую всегда последние версии, скажем, Ubuntu/Mint/SUSE. И пытаюсь установить туда самую первую версию OpenOffice или Thunderbird. Они не встанут? Ведь им нужны какие-то пакеты для удоволетворения зависимостей, а эти пакеты новых версий, и будет несовместимость?
Пользую Arch Linux. Ну, вы знаете - "не было печали - апдейтов накачали".

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

А зачем, собственно?

Virgil
Неотъемлемая часть форума
Сообщения: 563
Зарегистрирован: 13 янв 2009, 01:33

Re: Проблема с установкой программ

Сообщение Virgil »

Вдруг новые версии какой-то определённой программы окажутся хуже старых... В Windows я уже с таким сталкивался.
Пользую Arch Linux. Ну, вы знаете - "не было печали - апдейтов накачали".

Аватара пользователя
IceMan
Неотъемлемая часть форума
Сообщения: 377
Зарегистрирован: 22 июл 2007, 10:12
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение IceMan »

Для этого можно использовать песочницу на основе chroot/openvz. Накладные расходы будут минимальны.

Virgil
Неотъемлемая часть форума
Сообщения: 563
Зарегистрирован: 13 янв 2009, 01:33

Re: Проблема с установкой программ

Сообщение Virgil »

Получается, GNU/Linux - очень неавтономная операционная система? Если использовать страрую версию дистрибутива, то ничего нельзя обновлять. Всё будет работать изкаробки. Как только задумаешь полезть в Интернет за обновлениями, сразу выяснится, что для удовлетворения зависимостей придётся обновить почти всё ПО, почти все пакеты, а то и версию дисрибутива... Так? То есть - либо пользуйся старьём во всём, либо получай последнее, что есть в репозиториях. Это просто размышления такие...
Пользую Arch Linux. Ну, вы знаете - "не было печали - апдейтов накачали".

dg333
Неотъемлемая часть форума
Сообщения: 293
Зарегистрирован: 10 май 2006, 09:46
Откуда: Менск

Re: Проблема с установкой программ

Сообщение dg333 »

Virgil, а навошта нешта абнаўляць, калі ўсё працуе?
openSUSE 11.3/12.3

Virgil
Неотъемлемая часть форума
Сообщения: 563
Зарегистрирован: 13 янв 2009, 01:33

Re: Проблема с установкой программ

Сообщение Virgil »

Я не понимаю... :|
Пользую Arch Linux. Ну, вы знаете - "не было печали - апдейтов накачали".

Аватара пользователя
Nyshtyak
Неотъемлемая часть форума
Сообщения: 235
Зарегистрирован: 22 ноя 2005, 18:23

Re: Проблема с установкой программ

Сообщение Nyshtyak »

Да, вот такая вот гадкая эта ОС.

Аватара пользователя
grub
Неотъемлемая часть форума
Сообщения: 849
Зарегистрирован: 13 сен 2006, 10:29
Откуда: Минск
Контактная информация:

Re: Проблема с установкой программ

Сообщение grub »

Virgil, если обновлять старую версию, она перестанет быть старой версией. Это совершенно очевидная логика, и архитектура ОС тут ни при чем.

Если же Вы имеете в виду, что Вам хочется обновлять только отдельные группы пакетов (или наоборот, не обновлять отдельные группы пакетов), то это можно сделать в определенных пределах. Но для начала придется разобраться с aptitude howto.

Ответить